Feature 10947: Add methods to create certificates
[osm/N2VC.git] / requirements.txt
1 #######################################################################################
2 # Copyright ETSI Contributors and Others.
3 #
4 # Licensed under the Apache License, Version 2.0 (the "License");
5 # you may not use this file except in compliance with the License.
6 # You may obtain a copy of the License at
7 #
8 #    http://www.apache.org/licenses/LICENSE-2.0
9 #
10 # Unless required by applicable law or agreed to in writing, software
11 # distributed under the License is distributed on an "AS IS" BASIS,
12 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
13 # implied.
14 # See the License for the specific language governing permissions and
15 # limitations under the License.
16 #######################################################################################
17 async-timeout==3.0.1
18     # via
19     #   -r requirements.in
20     #   retrying-async
21 bcrypt==3.2.2
22     # via paramiko
23 cachetools==5.2.0
24     # via google-auth
25 certifi==2022.6.15
26     # via
27     #   kubernetes
28     #   requests
29 cffi==1.15.0
30     # via
31     #   bcrypt
32     #   cryptography
33     #   pynacl
34 charset-normalizer==2.0.12
35     # via requests
36 cryptography==37.0.2
37     # via paramiko
38 google-auth==2.8.0
39     # via kubernetes
40 idna==3.3
41     # via requests
42 juju==2.9.10
43     # via -r requirements.in
44 jujubundlelib==0.5.7
45     # via theblues
46 kubernetes==24.2.0
47     # via
48     #   -r requirements.in
49     #   juju
50 macaroonbakery==1.3.1
51     # via
52     #   juju
53     #   theblues
54 motor==1.3.1
55     # via -r requirements.in
56 mypy-extensions==0.4.3
57     # via typing-inspect
58 oauthlib==3.2.0
59     # via requests-oauthlib
60 paramiko==2.11.0
61     # via juju
62 protobuf==3.20.1
63     # via macaroonbakery
64 pyasn1==0.4.8
65     # via
66     #   -r requirements.in
67     #   juju
68     #   pyasn1-modules
69     #   rsa
70 pyasn1-modules==0.2.8
71     # via google-auth
72 pycparser==2.21
73     # via cffi
74 pymacaroons==0.13.0
75     # via macaroonbakery
76 pymongo==3.12.3
77     # via motor
78 pynacl==1.5.0
79     # via
80     #   macaroonbakery
81     #   paramiko
82     #   pymacaroons
83 pyrfc3339==1.1
84     # via
85     #   juju
86     #   macaroonbakery
87 python-dateutil==2.8.2
88     # via kubernetes
89 pytz==2022.1
90     # via pyrfc3339
91 pyyaml==5.4.1
92     # via
93     #   -r requirements.in
94     #   juju
95     #   jujubundlelib
96     #   kubernetes
97 requests==2.28.0
98     # via
99     #   kubernetes
100     #   macaroonbakery
101     #   requests-oauthlib
102     #   theblues
103 requests-oauthlib==1.3.1
104     # via kubernetes
105 retrying-async==2.0.0
106     # via -r requirements.in
107 rsa==4.8
108     # via google-auth
109 six==1.16.0
110     # via
111     #   google-auth
112     #   kubernetes
113     #   macaroonbakery
114     #   paramiko
115     #   pymacaroons
116     #   python-dateutil
117 theblues==0.5.2
118     # via juju
119 toposort==1.7
120     # via juju
121 typing-extensions==4.2.0
122     # via typing-inspect
123 typing-inspect==0.7.1
124     # via juju
125 urllib3==1.26.9
126     # via
127     #   kubernetes
128     #   requests
129 websocket-client==1.3.3
130     # via kubernetes
131 websockets==7.0
132     # via juju
133
134 # The following packages are considered to be unsafe in a requirements file:
135 # setuptools