Fixing bug 1437
[osm/RO.git] / RO-VIM-fos / debian / python3-osm-rovim-fos.postinst
1 #!/bin/bash
2
3 ##
4 # Licensed under the Apache License, Version 2.0 (the "License"); you may
5 # not use this file except in compliance with the License. You may obtain
6 # a copy of the License at
7 #
8 #         http://www.apache.org/licenses/LICENSE-2.0
9 #
10 # Unless required by applicable law or agreed to in writing, software
11 # distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
12 # WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
13 # License for the specific language governing permissions and limitations
14 # under the License.
15 #
16 # For those usages not covered by the Apache License, Version 2.0 please
17 # contact with: OSM_TECH@list.etsi.org
18 ##
19
20 echo "POST INSTALL OSM-ROVIM-FOS"
21
22 #Pip packages required for Eclipse fog05 connector
23 curl -Lo /tmp/libzenohc.so https://github.com/eclipse-fog05/fog05/releases/download/v0.1.0/libzenohc.so
24 mv /tmp/libzenohc.so /usr/local/lib/libzenohc.so
25 python3 -m pip install pyangbind sphinx zenoh==0.3.0 yaks==0.3.0.post1 fog05-sdk==0.2.0 fog05==0.2.0
26