update from RIFT as of 696b75d2fe9fb046261b08c616f1bcf6c0b54a9b second try
[osm/SO.git] / rwlaunchpad / plugins / rwresmgr / CMakeLists.txt
index e757e43..fdeea7b 100644 (file)
@@ -24,7 +24,7 @@ set(TASKLET_NAME rwresmgrtasklet)
 ##
 # This function creates an install target for the plugin artifacts
 ##
-rift_install_python_plugin(${TASKLET_NAME} ${TASKLET_NAME}.py)
+rift_install_gobject_python_plugin(${TASKLET_NAME} ${TASKLET_NAME}.py COMPONENT ${INSTALL_COMPONENT})
 
 # Workaround RIFT-6485 - rpmbuild defaults to python2 for
 # anything not in a site-packages directory so we have to
@@ -37,5 +37,5 @@ rift_python_install_tree(
     rift/tasklets/${TASKLET_NAME}/rwresmgr_config.py
     rift/tasklets/${TASKLET_NAME}/rwresmgr_core.py
     rift/tasklets/${TASKLET_NAME}/rwresmgr_events.py
-  COMPONENT ${PKG_LONG_NAME}
+  COMPONENT ${INSTALL_COMPONENT}
   PYTHON3_ONLY)