Fix bug 1598 - tweaking timings in the locks
[osm/RO.git] / RO-SDN-onos_vpls / setup.py
index b015e67..bedbd79 100644 (file)
 from setuptools import setup
 
 _name = "osm_rosdn_onos_vpls"
+_version_command = ("git describe --match v* --tags --long --dirty", "pep440-git-full")
+_description = "OSM ro sdn plugin for ONOS VPLS"
+_author = "OSM Support"
+_author_email = "osmsupport@etsi.org"
+_maintainer = "OSM Support"
+_maintainer_email = "osmsupport@etsi.org"
+_license = "Apache 2.0"
+_url = "https://osm.etsi.org/gitweb/?p=osm/RO.git;a=summary"
 
-README = """
+_readme = """
 ===========
 osm-rosdn_onos_vpls
 ===========
@@ -30,26 +38,21 @@ osm-ro pluging for ONOS VPLS SDN
 
 setup(
     name=_name,
-    description='OSM ro sdn plugin for ONOS VPLS',
-    long_description=README,
-    version_command=('git describe --match v* --tags --long --dirty', 'pep440-git-full'),
-    # version=VERSION,
-    # python_requires='>3.5.0',
-    author='ETSI OSM',
-    # TODO py3 author_email='',
-    maintainer='OSM_TECH@LIST.ETSI.ORG',  # TODO py3
-    # TODO py3 maintainer_email='',
-    url='https://osm.etsi.org/gitweb/?p=osm/RO.git;a=summary',
-    license='Apache 2.0',
-
+    description=_description,
+    long_description=_readme,
+    version_command=_version_command,
+    author=_author,
+    author_email=_author_email,
+    maintainer=_maintainer,
+    maintainer_email=_maintainer_email,
+    url=_url,
+    license=_license,
     packages=[_name],
     include_package_data=True,
-    install_requires=[
-        "requests",
-        "osm-ro @ git+https://osm.etsi.org/gerrit/osm/RO.git#egg=osm-ro&subdirectory=RO"
-    ],
-    setup_requires=['setuptools-version-command'],
+    setup_requires=["setuptools-version-command"],
     entry_points={
-        'osm_rosdn.plugins': ['rosdn_onos_vpls = osm_rosdn_onos_vpls.sdn_assist_onos_vpls:OnosVpls'],
+        "osm_rosdn.plugins": [
+            "rosdn_onos_vpls = osm_rosdn_onos_vpls.sdn_assist_onos_vpls:OnosVpls"
+        ],
     },
 )