27c904407e9cca93e2538824ff41b0af25f36eec
[osm/RO.git] / RO-client / debian / python3-osm-roclient.postinst
1 #!/bin/bash
2
3 ##
4 # Licensed under the Apache License, Version 2.0 (the "License"); you may
5 # not use this file except in compliance with the License. You may obtain
6 # a copy of the License at
7 #
8 #         http://www.apache.org/licenses/LICENSE-2.0
9 #
10 # Unless required by applicable law or agreed to in writing, software
11 # distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
12 # WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
13 # License for the specific language governing permissions and limitations
14 # under the License.
15 ##
16
17
18 #configure arg-autocomplete for RO-client
19 su $SUDO_USER -c 'activate-global-python-argcomplete --user'
20 if ! su  $SUDO_USER -c 'grep -q bash_completion.d/python-argcomplete.sh ${HOME}/.bashrc'
21 then
22     echo "    inserting .bash_completion.d/python-argcomplete.sh execution at .bashrc"
23     su $SUDO_USER -c 'echo ". ${HOME}/.bash_completion.d/python-argcomplete.sh" >> ~/.bashrc'
24 fi
25