e7ce877e4b2a47babf8a37b207587ef320e38483
[osm/RO.git] / RO-VIM-vmware / debian / python3-osm-rovim-vmware.postinst
1 #!/bin/bash
2
3 ##
4 # Copyright VMware Inc.
5 # Licensed under the Apache License, Version 2.0 (the "License"); you may
6 # not use this file except in compliance with the License. You may obtain
7 # a copy of the License at
8 #
9 #         http://www.apache.org/licenses/LICENSE-2.0
10 #
11 # Unless required by applicable law or agreed to in writing, software
12 # distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
13 # WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
14 # License for the specific language governing permissions and limitations
15 # under the License.
16 #
17 # For those usages not covered by the Apache License, Version 2.0 please
18 # contact with: OSM_TECH@list.etsi.org
19 ##
20
21 echo "POST INSTALL OSM-ROVIM-VMWARE"
22
23 #Pip packages required for vmware connector
24 python3 -m pip install --upgrade pip
25 python3 -m pip install --upgrade pyvcloud==19.1.1
26 python3 -m pip install --upgrade progressbar
27 python3 -m pip install --upgrade pyvmomi
28 # python3 -m pip install --upgrade prettytable
29 # python3 -m pip install --upgrade pyang pyangbind