Fix Dockerfile.local
[osm/NBI.git] / setup.py
index f134876..ad987ac 100644 (file)
--- a/setup.py
+++ b/setup.py
@@ -35,27 +35,13 @@ setup(
     # version=VERSION,
     # python_requires='>3.5.0',
     author='ETSI OSM',
-    author_email='alfonso.tiernosepulveda@telefonica.com',
-    maintainer='Alfonso Tierno',
-    maintainer_email='alfonso.tiernosepulveda@telefonica.com',
+    author_email='osmsupport@etsi.org',
+    maintainer='ETSI OSM',
+    maintainer_email='osmsupport@etsi.org',
     url='https://osm.etsi.org/gitweb/?p=osm/NBI.git;a=summary',
     license='Apache 2.0',
 
     packages=find_packages(exclude=["temp", "local"]),
     include_package_data=True,
-    # exclude_package_data={'': ['osm_nbi/local', 'temp']},
-    # data_files=[('/etc/osm/', ['osm_nbi/nbi.cfg']),
-    #             ('/etc/systemd/system/', ['osm_nbi/osm-nbi.service']),
-    #             ],
-    install_requires=[
-        'CherryPy==18.1.2',
-        'osm-common @ git+https://osm.etsi.org/gerrit/osm/common.git#egg=osm-common',
-        'jsonschema==3.2.0',
-        'PyYAML',
-        'osm-im @ git+https://osm.etsi.org/gerrit/osm/IM.git#egg=osm-im',
-        'python-keystoneclient',
-        'requests',
-        'aiohttp>=2.3.10',
-    ],
     setup_requires=['setuptools-version-command'],
 )