fix 1272. Fixing aiohttp version to 3.6.2
[osm/NBI.git] / setup.py
index 7d8a31d..309dda1 100644 (file)
--- a/setup.py
+++ b/setup.py
@@ -17,7 +17,7 @@
 # limitations under the License.
 
 import os
 # limitations under the License.
 
 import os
-from setuptools import setup
+from setuptools import setup, find_packages
 
 _name = "osm_nbi"
 # version is at first line of osm_nbi/html_public/version
 
 _name = "osm_nbi"
 # version is at first line of osm_nbi/html_public/version
@@ -41,23 +41,21 @@ setup(
     url='https://osm.etsi.org/gitweb/?p=osm/NBI.git;a=summary',
     license='Apache 2.0',
 
     url='https://osm.etsi.org/gitweb/?p=osm/NBI.git;a=summary',
     license='Apache 2.0',
 
-    packages=[_name],
+    packages=find_packages(exclude=["temp", "local"]),
     include_package_data=True,
     # exclude_package_data={'': ['osm_nbi/local', 'temp']},
     # data_files=[('/etc/osm/', ['osm_nbi/nbi.cfg']),
     #             ('/etc/systemd/system/', ['osm_nbi/osm-nbi.service']),
     #             ],
     include_package_data=True,
     # exclude_package_data={'': ['osm_nbi/local', 'temp']},
     # data_files=[('/etc/osm/', ['osm_nbi/nbi.cfg']),
     #             ('/etc/systemd/system/', ['osm_nbi/osm-nbi.service']),
     #             ],
-    dependency_links=[
-        "git+https://osm.etsi.org/gerrit/osm/IM.git#egg=osm-im",
-        'git+https://osm.etsi.org/gerrit/osm/common.git#egg=osm-common'
-    ],
     install_requires=[
     install_requires=[
-        'CherryPy==18.0.0',
-        'osm-common',
-        'jsonschema',
+        'CherryPy>=18.1.2',
+        'osm-common @ git+https://osm.etsi.org/gerrit/osm/common.git#egg=osm-common',
+        'jsonschema>=3.2.0',
         'PyYAML',
         'PyYAML',
-        'osm-im',
-        'python-keystoneclient'
+        'osm-im @ git+https://osm.etsi.org/gerrit/osm/IM.git#egg=osm-im',
+        'python-keystoneclient',
+        'requests',
+        'aiohttp>=2.3.10,<=3.6.2',
     ],
     setup_requires=['setuptools-version-command'],
 )
     ],
     setup_requires=['setuptools-version-command'],
 )