Removing old incompatible versions of roles_operations
[osm/NBI.git] / osm_nbi / validation.py
index b20be4a..ba2451b 100644 (file)
@@ -381,7 +381,7 @@ vim_account_new_schema = {
         "description": description_schema,
         "vim": name_schema,
         "datacenter": name_schema,
-        "vim_type": {"enum": ["openstack", "openvim", "vmware", "opennebula", "aws"]},
+        "vim_type": {"enum": ["openstack", "openvim", "vmware", "opennebula", "aws", "azure"]},
         "vim_url": description_schema,
         # "vim_url_admin": description_schema,
         # "vim_tenant": name_schema,
@@ -421,7 +421,7 @@ wim_account_new_schema = {
         "name": name_schema,
         "description": description_schema,
         "wim": name_schema,
-        "wim_type": {"enum": ["tapi", "onos", "odl", "dynpac"]},
+        "wim_type": {"enum": ["tapi", "onos", "odl", "dynpac", "fake"]},
         "wim_url": description_schema,
         "user": shortname_schema,
         "password": passwd_schema,